const regex = /.*\s([[:digit:]]*)\s(?:of|[\/])\s([[:digit:]]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\s([[:digit:]]*)\\s(?:of|[\\\/])\\s([[:digit:]]+)', 'gm')
const str = `Page 102 of 10
Slide 10 of 10
Page 102 / 10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}