import Foundation
let pattern = #"(\b\w+\b) (\b\w+\b) (\b\w+\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"aaa bbb ccc"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U\1\U\2\U\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)