// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b\w+\b) (\b\w+\b) (\b\w+\b)").unwrap();
let string = "aaa bbb ccc";
let substitution = "\\U\\1\\U\\2\\U\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}