re = /(\b\w+\b) (\b\w+\b) (\b\w+\b)/m
str = 'aaa bbb ccc'
subst = '\\U\\1\\U\\2\\U\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result