using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w+\b) (\b\w+\b) (\b\w+\b)";
string substitution = @"\U\1\U\2\U\3";
string input = @"aaa bbb ccc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}