package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\b\w+\b) (\b\w+\b) (\b\w+\b)`)
var str = `aaa bbb ccc`
var substitution = "\U\1\U\2\U\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}