$re = '/(\b\w+\b) (\b\w+\b) (\b\w+\b)/m';
$str = 'aaa bbb ccc';
$subst = "\U\1\U\2\U\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;