import Foundation
let pattern = #"^[A-Z]{3}(([1-9]{4})|([1-9]{1}[A-Z{1}][1-9]{2}))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABC1D23
ABC1Z23
ABC1ZA3
AB11Z23
ABC·1234
ABC1234
asasdasdads
1231321321
111ab12
ABC1423
ABC1423ABC
ABC
1234
12345
123456
12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)