# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Z]{3}(([1-9]{4})|([1-9]{1}[A-Z{1}][1-9]{2}))$"
test_str = ("ABC1D23\n"
"ABC1Z23\n"
"ABC1ZA3\n"
"AB11Z23\n"
"ABC·1234\n"
"ABC1234\n"
"asasdasdads\n"
"1231321321\n"
"111ab12\n"
"ABC1423\n"
"ABC1423ABC\n"
"ABC\n"
"1234\n"
"12345\n"
"123456\n"
"12\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.