import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]{3}(([1-9]{4})|([1-9]{1}[A-Z{1}][1-9]{2}))$";
final String string = "ABC1D23\n"
+ "ABC1Z23\n"
+ "ABC1ZA3\n"
+ "AB11Z23\n"
+ "ABC·1234\n"
+ "ABC1234\n"
+ "asasdasdads\n"
+ "1231321321\n"
+ "111ab12\n"
+ "ABC1423\n"
+ "ABC1423ABC\n"
+ "ABC\n"
+ "1234\n"
+ "12345\n"
+ "123456\n"
+ "12\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}