use strict;
my $str = 'ABC1D23
ABC1Z23
ABC1ZA3
AB11Z23
ABC·1234
ABC1234
asasdasdads
1231321321
111ab12
ABC1423
ABC1423ABC
ABC
1234
12345
123456
12
';
my $regex = qr/^[A-Z]{3}(([1-9]{4})|([1-9]{1}[A-Z{1}][1-9]{2}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}