const regex = /^[A-Z]{3}(([1-9]{4})|([1-9]{1}[A-Z{1}][1-9]{2}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]{3}(([1-9]{4})|([1-9]{1}[A-Z{1}][1-9]{2}))$', 'gm')
const str = `ABC1D23
ABC1Z23
ABC1ZA3
AB11Z23
ABC·1234
ABC1234
asasdasdads
1231321321
111ab12
ABC1423
ABC1423ABC
ABC
1234
12345
123456
12
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}