#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]{3}(([1-9]{4})|([1-9]{1}[A-Z{1}][1-9]{2}))$"
Local $sString = "ABC1D23" & @CRLF & _
"ABC1Z23" & @CRLF & _
"ABC1ZA3" & @CRLF & _
"AB11Z23" & @CRLF & _
"ABC·1234" & @CRLF & _
"ABC1234" & @CRLF & _
"asasdasdads" & @CRLF & _
"1231321321" & @CRLF & _
"111ab12" & @CRLF & _
"ABC1423" & @CRLF & _
"ABC1423ABC" & @CRLF & _
"ABC" & @CRLF & _
"1234" & @CRLF & _
"12345" & @CRLF & _
"123456" & @CRLF & _
"12" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")