package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]{3}(([1-9]{4})|([1-9]{1}[A-Z{1}][1-9]{2}))$`)
var str = `ABC1D23
ABC1Z23
ABC1ZA3
AB11Z23
ABC·1234
ABC1234
asasdasdads
1231321321
111ab12
ABC1423
ABC1423ABC
ABC
1234
12345
123456
12
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}