// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?<fullMatch>(?<prop>\w+\s*=\s*)({)(?<quote1>["'`])(?<string>[^"$'`{}]*)(?<quote2>["'`])(}))"#).unwrap();
let string = "<ReactComponent
property={true}
target={'string'}
/>
export const ReactComponent = () => <div property target={\"string\"} />
<ReactComponent
property={true}
target={`string`}
/>";
let substitution = "$2$4$5$6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}