package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<fullMatch>(?<prop>\w+\s*=\s*)({)(?<quote1>["'`])(?<string>[^"$'`{}]*)(?<quote2>["'`])(}))`)
var str = `<ReactComponent
property={true}
target={'string'}
/>
export const ReactComponent = () => <div property target={"string"} />
<ReactComponent
property={true}
target={\`string\`}
/>`
var substitution = "$2$4$5$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}