using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<fullMatch>(?<prop>\w+\s*=\s*)({)(?<quote1>[""'`])(?<string>[^""$'`{}]*)(?<quote2>[""'`])(}))";
string substitution = @"$2$4$5$6";
string input = @"<ReactComponent
property={true}
target={'string'}
/>
export const ReactComponent = () => <div property target={""string""} />
<ReactComponent
property={true}
target={`string`}
/>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}