use strict;
my $str = '<ReactComponent
property={true}
target={\'string\'}
/>
export const ReactComponent = () => <div property target={"string"} />
<ReactComponent
property={true}
target={`string`}
/>';
my $regex = qr/(?<fullMatch>(?<prop>\w+\s*=\s*)({)(?<quote1>["'`])(?<string>[^"$'`{}]*)(?<quote2>["'`])(}))/mp;
my $subst = '$2$4$5$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";