# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<fullMatch>(?<prop>\w+\s*=\s*)({)(?<quote1>[\"'`])(?<string>[^\"$'`{}]*)(?<quote2>[\"'`])(}))"
test_str = ("<ReactComponent\n"
" property={true}\n"
" target={'string'}\n"
"/>\n\n"
"export const ReactComponent = () => <div property target={\"string\"} />\n\n"
"<ReactComponent\n"
" property={true}\n"
" target={`string`}\n"
"/>")
subst = "$2$4$5$6"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.