# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<fullMatch>(?<prop>\w+\s*=\s*)({)(?<quote1>["'`])(?<string>[^"$'`{}]*)(?<quote2>["'`])(}))/$2$4$5$6/gm;t' <<< "<ReactComponent
property={true}
target={'string'}
/>
export const ReactComponent = () => <div property target={\"string\"} />
<ReactComponent
property={true}
target={`string`}
/>"