const regex = /(?<fullMatch>(?<prop>\w+\s*=\s*)({)(?<quote1>["'`])(?<string>[^"$'`{}]*)(?<quote2>["'`])(}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<fullMatch>(?<prop>\\w+\\s*=\\s*)({)(?<quote1>["\'`])(?<string>[^"$\'`{}]*)(?<quote2>["\'`])(}))', 'gm')
const str = `<ReactComponent
property={true}
target={'string'}
/>
export const ReactComponent = () => <div property target={"string"} />
<ReactComponent
property={true}
target={\`string\`}
/>`;
const subst = `$2$4$5$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);