// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):(\s{2,})[\n|\w.]$").unwrap();
let string = " no_result:
label: Nous n'avons pas trouvé de bien correspondant à la recherche.
suggestion: Suggestion de biens dans les environs
change_criteria: Vous pouvez modifier les critères de
of: de
or: ou de
filter:
type: type de bien
location: localisation
size: nombre de pièces
price: budget
style: style de bien";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}