import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":(\\s{2,})[\\n|\\w.]$";
final String string = " no_result:\n"
+ " label: Nous n'avons pas trouvé de bien correspondant à la recherche.\n"
+ " suggestion: Suggestion de biens dans les environs\n"
+ " change_criteria: Vous pouvez modifier les critères de\n"
+ " of: de\n"
+ " or: ou de\n"
+ " filter:\n"
+ " type: type de bien\n"
+ " location: localisation\n"
+ " size: nombre de pièces\n"
+ " price: budget\n"
+ " style: style de bien";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}