$re = '/:(\s{2,})[\n|\w.]$/m';
$str = ' no_result:
label: Nous n\'avons pas trouvé de bien correspondant à la recherche.
suggestion: Suggestion de biens dans les environs
change_criteria: Vous pouvez modifier les critères de
of: de
or: ou de
filter:
type: type de bien
location: localisation
size: nombre de pièces
price: budget
style: style de bien';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);