using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":(\s{2,})[\n|\w.]$";
string input = @" no_result:
label: Nous n'avons pas trouvé de bien correspondant à la recherche.
suggestion: Suggestion de biens dans les environs
change_criteria: Vous pouvez modifier les critères de
of: de
or: ou de
filter:
type: type de bien
location: localisation
size: nombre de pièces
price: budget
style: style de bien";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}