package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):(\s{2,})[\n|\w.]$`)
var str = ` no_result:
label: Nous n'avons pas trouvé de bien correspondant à la recherche.
suggestion: Suggestion de biens dans les environs
change_criteria: Vous pouvez modifier les critères de
of: de
or: ou de
filter:
type: type de bien
location: localisation
size: nombre de pièces
price: budget
style: style de bien`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}