use strict;
my $str = ' no_result:
label: Nous n\'avons pas trouvé de bien correspondant à la recherche.
suggestion: Suggestion de biens dans les environs
change_criteria: Vous pouvez modifier les critères de
of: de
or: ou de
filter:
type: type de bien
location: localisation
size: nombre de pièces
price: budget
style: style de bien';
my $regex = qr/:(\s{2,})[\n|\w.]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}