#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m):(\s{2,})[\n|\w.]$"
Local $sString = " no_result:" & @CRLF & _
" label: Nous n'avons pas trouvé de bien correspondant à la recherche." & @CRLF & _
" suggestion: Suggestion de biens dans les environs" & @CRLF & _
" change_criteria: Vous pouvez modifier les critères de" & @CRLF & _
" of: de" & @CRLF & _
" or: ou de" & @CRLF & _
" filter:" & @CRLF & _
" type: type de bien" & @CRLF & _
" location: localisation" & @CRLF & _
" size: nombre de pièces" & @CRLF & _
" price: budget" & @CRLF & _
" style: style de bien"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")