import Foundation
let pattern = #"^([^;,\n]*);.*(\b\1\b=|;)(true)(,.*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# with k/v pairs declared
http-metrics;http-metrics=true,grpc=false,ssh=false;
http-metrics;http-metrics=true,grpc=true,ssh=false;
http-metrics;http-metrics=true,grpc=true,ssh=true;
http-metrics;http-metrics=false,grpc=false,ssh=false;
http-metrics;http-metrics=false,grpc=true,ssh=false;
http-metrics;http-metrics=false,grpc=true,ssh=true;
http-metrics;;http-metrics=true,grpc=false,ssh=false
http-metrics;;http-metrics=true,grpc=true,ssh=false
http-metrics;;http-metrics=true,grpc=true,ssh=true
http-metrics;;http-metrics=false,grpc=false,ssh=false
http-metrics;;http-metrics=false,grpc=true,ssh=false
http-metrics;;http-metrics=false,grpc=true,ssh=true
grpc;http-metrics=true,grpc=false,ssh=false;
grpc;http-metrics=true,grpc=true,ssh=false;
grpc;http-metrics=true,grpc=true,ssh=true;
grpc;http-metrics=false,grpc=false,ssh=false;
grpc;http-metrics=false,grpc=true,ssh=false;
grpc;http-metrics=false,grpc=true,ssh=true;
# without k/v pairs declared
http-metrics;true;
http-metrics;;true
http-metrics;false;true
;;true
;;
;false;
;;false
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)