use strict;
my $str = '# with k/v pairs declared
http-metrics;http-metrics=true,grpc=false,ssh=false;
http-metrics;http-metrics=true,grpc=true,ssh=false;
http-metrics;http-metrics=true,grpc=true,ssh=true;
http-metrics;http-metrics=false,grpc=false,ssh=false;
http-metrics;http-metrics=false,grpc=true,ssh=false;
http-metrics;http-metrics=false,grpc=true,ssh=true;
http-metrics;;http-metrics=true,grpc=false,ssh=false
http-metrics;;http-metrics=true,grpc=true,ssh=false
http-metrics;;http-metrics=true,grpc=true,ssh=true
http-metrics;;http-metrics=false,grpc=false,ssh=false
http-metrics;;http-metrics=false,grpc=true,ssh=false
http-metrics;;http-metrics=false,grpc=true,ssh=true
grpc;http-metrics=true,grpc=false,ssh=false;
grpc;http-metrics=true,grpc=true,ssh=false;
grpc;http-metrics=true,grpc=true,ssh=true;
grpc;http-metrics=false,grpc=false,ssh=false;
grpc;http-metrics=false,grpc=true,ssh=false;
grpc;http-metrics=false,grpc=true,ssh=true;
# without k/v pairs declared
http-metrics;true;
http-metrics;;true
http-metrics;false;true
;;true
;;
;false;
;;false';
my $regex = qr/^([^;,\n]*);.*(\b\1\b=|;)(true)(,.*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}