re = /^([^;,\n]*);.*(\b\1\b=|;)(true)(,.*)?$/m
str = '# with k/v pairs declared
http-metrics;http-metrics=true,grpc=false,ssh=false;
http-metrics;http-metrics=true,grpc=true,ssh=false;
http-metrics;http-metrics=true,grpc=true,ssh=true;
http-metrics;http-metrics=false,grpc=false,ssh=false;
http-metrics;http-metrics=false,grpc=true,ssh=false;
http-metrics;http-metrics=false,grpc=true,ssh=true;
http-metrics;;http-metrics=true,grpc=false,ssh=false
http-metrics;;http-metrics=true,grpc=true,ssh=false
http-metrics;;http-metrics=true,grpc=true,ssh=true
http-metrics;;http-metrics=false,grpc=false,ssh=false
http-metrics;;http-metrics=false,grpc=true,ssh=false
http-metrics;;http-metrics=false,grpc=true,ssh=true
grpc;http-metrics=true,grpc=false,ssh=false;
grpc;http-metrics=true,grpc=true,ssh=false;
grpc;http-metrics=true,grpc=true,ssh=true;
grpc;http-metrics=false,grpc=false,ssh=false;
grpc;http-metrics=false,grpc=true,ssh=false;
grpc;http-metrics=false,grpc=true,ssh=true;
# without k/v pairs declared
http-metrics;true;
http-metrics;;true
http-metrics;false;true
;;true
;;
;false;
;;false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end