import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^;,\\n]*);.*(\\b\\1\\b=|;)(true)(,.*)?$";
final String string = "# with k/v pairs declared\n"
+ "http-metrics;http-metrics=true,grpc=false,ssh=false;\n"
+ "http-metrics;http-metrics=true,grpc=true,ssh=false;\n"
+ "http-metrics;http-metrics=true,grpc=true,ssh=true;\n"
+ "http-metrics;http-metrics=false,grpc=false,ssh=false;\n"
+ "http-metrics;http-metrics=false,grpc=true,ssh=false;\n"
+ "http-metrics;http-metrics=false,grpc=true,ssh=true;\n"
+ "http-metrics;;http-metrics=true,grpc=false,ssh=false\n"
+ "http-metrics;;http-metrics=true,grpc=true,ssh=false\n"
+ "http-metrics;;http-metrics=true,grpc=true,ssh=true\n"
+ "http-metrics;;http-metrics=false,grpc=false,ssh=false\n"
+ "http-metrics;;http-metrics=false,grpc=true,ssh=false\n"
+ "http-metrics;;http-metrics=false,grpc=true,ssh=true\n"
+ "grpc;http-metrics=true,grpc=false,ssh=false;\n"
+ "grpc;http-metrics=true,grpc=true,ssh=false;\n"
+ "grpc;http-metrics=true,grpc=true,ssh=true;\n"
+ "grpc;http-metrics=false,grpc=false,ssh=false;\n"
+ "grpc;http-metrics=false,grpc=true,ssh=false;\n"
+ "grpc;http-metrics=false,grpc=true,ssh=true;\n\n"
+ "# without k/v pairs declared \n"
+ "http-metrics;true;\n"
+ "http-metrics;;true\n"
+ "http-metrics;false;true\n"
+ ";;true\n"
+ ";;\n"
+ ";false;\n"
+ ";;false";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}