using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^;,\n]*);.*(\b\1\b=|;)(true)(,.*)?$";
string input = @"# with k/v pairs declared
http-metrics;http-metrics=true,grpc=false,ssh=false;
http-metrics;http-metrics=true,grpc=true,ssh=false;
http-metrics;http-metrics=true,grpc=true,ssh=true;
http-metrics;http-metrics=false,grpc=false,ssh=false;
http-metrics;http-metrics=false,grpc=true,ssh=false;
http-metrics;http-metrics=false,grpc=true,ssh=true;
http-metrics;;http-metrics=true,grpc=false,ssh=false
http-metrics;;http-metrics=true,grpc=true,ssh=false
http-metrics;;http-metrics=true,grpc=true,ssh=true
http-metrics;;http-metrics=false,grpc=false,ssh=false
http-metrics;;http-metrics=false,grpc=true,ssh=false
http-metrics;;http-metrics=false,grpc=true,ssh=true
grpc;http-metrics=true,grpc=false,ssh=false;
grpc;http-metrics=true,grpc=true,ssh=false;
grpc;http-metrics=true,grpc=true,ssh=true;
grpc;http-metrics=false,grpc=false,ssh=false;
grpc;http-metrics=false,grpc=true,ssh=false;
grpc;http-metrics=false,grpc=true,ssh=true;
# without k/v pairs declared
http-metrics;true;
http-metrics;;true
http-metrics;false;true
;;true
;;
;false;
;;false";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}