# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^;,\n]*);.*(\b\1\b=|;)(true)(,.*)?$"
test_str = ("# with k/v pairs declared\n"
"http-metrics;http-metrics=true,grpc=false,ssh=false;\n"
"http-metrics;http-metrics=true,grpc=true,ssh=false;\n"
"http-metrics;http-metrics=true,grpc=true,ssh=true;\n"
"http-metrics;http-metrics=false,grpc=false,ssh=false;\n"
"http-metrics;http-metrics=false,grpc=true,ssh=false;\n"
"http-metrics;http-metrics=false,grpc=true,ssh=true;\n"
"http-metrics;;http-metrics=true,grpc=false,ssh=false\n"
"http-metrics;;http-metrics=true,grpc=true,ssh=false\n"
"http-metrics;;http-metrics=true,grpc=true,ssh=true\n"
"http-metrics;;http-metrics=false,grpc=false,ssh=false\n"
"http-metrics;;http-metrics=false,grpc=true,ssh=false\n"
"http-metrics;;http-metrics=false,grpc=true,ssh=true\n"
"grpc;http-metrics=true,grpc=false,ssh=false;\n"
"grpc;http-metrics=true,grpc=true,ssh=false;\n"
"grpc;http-metrics=true,grpc=true,ssh=true;\n"
"grpc;http-metrics=false,grpc=false,ssh=false;\n"
"grpc;http-metrics=false,grpc=true,ssh=false;\n"
"grpc;http-metrics=false,grpc=true,ssh=true;\n\n"
"# without k/v pairs declared \n"
"http-metrics;true;\n"
"http-metrics;;true\n"
"http-metrics;false;true\n"
";;true\n"
";;\n"
";false;\n"
";;false")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.