#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^;,\n]*);.*(\b\1\b=|;)(true)(,.*)?$"
Local $sString = "# with k/v pairs declared" & @CRLF & _
"http-metrics;http-metrics=true,grpc=false,ssh=false;" & @CRLF & _
"http-metrics;http-metrics=true,grpc=true,ssh=false;" & @CRLF & _
"http-metrics;http-metrics=true,grpc=true,ssh=true;" & @CRLF & _
"http-metrics;http-metrics=false,grpc=false,ssh=false;" & @CRLF & _
"http-metrics;http-metrics=false,grpc=true,ssh=false;" & @CRLF & _
"http-metrics;http-metrics=false,grpc=true,ssh=true;" & @CRLF & _
"http-metrics;;http-metrics=true,grpc=false,ssh=false" & @CRLF & _
"http-metrics;;http-metrics=true,grpc=true,ssh=false" & @CRLF & _
"http-metrics;;http-metrics=true,grpc=true,ssh=true" & @CRLF & _
"http-metrics;;http-metrics=false,grpc=false,ssh=false" & @CRLF & _
"http-metrics;;http-metrics=false,grpc=true,ssh=false" & @CRLF & _
"http-metrics;;http-metrics=false,grpc=true,ssh=true" & @CRLF & _
"grpc;http-metrics=true,grpc=false,ssh=false;" & @CRLF & _
"grpc;http-metrics=true,grpc=true,ssh=false;" & @CRLF & _
"grpc;http-metrics=true,grpc=true,ssh=true;" & @CRLF & _
"grpc;http-metrics=false,grpc=false,ssh=false;" & @CRLF & _
"grpc;http-metrics=false,grpc=true,ssh=false;" & @CRLF & _
"grpc;http-metrics=false,grpc=true,ssh=true;" & @CRLF & _
"" & @CRLF & _
"# without k/v pairs declared " & @CRLF & _
"http-metrics;true;" & @CRLF & _
"http-metrics;;true" & @CRLF & _
"http-metrics;false;true" & @CRLF & _
";;true" & @CRLF & _
";;" & @CRLF & _
";false;" & @CRLF & _
";;false"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")