import Foundation
let pattern = #"\/([\w\-]+)(.git)?(@([\w\-\.]+))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git
https://github.com/defenseunicorns/zarf.git
ghcr.io/stefanprodan/podinfo_fasd-123.git
k3d-cluster.localhost/defenseunicorns/zarf-agent
localhost:5000/some-cool-image
ghcr.io/stefanprodan/podinfo@6.0.0
stefanprodan/podinfo.git@adf0fasd10.1.223124123123-asdf
https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git@0.0.9-bb.0
stefanprodan/podinfo@adf0fasd10.1.223124123123-asdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)