use strict;
my $str = 'https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git
https://github.com/defenseunicorns/zarf.git
ghcr.io/stefanprodan/podinfo_fasd-123.git
k3d-cluster.localhost/defenseunicorns/zarf-agent
localhost:5000/some-cool-image
ghcr.io/stefanprodan/podinfo@6.0.0
stefanprodan/podinfo.git@adf0fasd10.1.223124123123-asdf
https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git@0.0.9-bb.0
stefanprodan/podinfo@adf0fasd10.1.223124123123-asdf
';
my $regex = qr`\/([\w\-]+)(.git)?(@([\w\-\.]+))?$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}