import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/([\\w\\-]+)(.git)?(@([\\w\\-\\.]+))?$";
final String string = "https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git\n"
+ "https://github.com/defenseunicorns/zarf.git\n"
+ "ghcr.io/stefanprodan/podinfo_fasd-123.git\n"
+ "k3d-cluster.localhost/defenseunicorns/zarf-agent\n"
+ "localhost:5000/some-cool-image\n"
+ "ghcr.io/stefanprodan/podinfo@6.0.0\n"
+ "stefanprodan/podinfo.git@adf0fasd10.1.223124123123-asdf\n"
+ "https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git@0.0.9-bb.0\n"
+ "stefanprodan/podinfo@adf0fasd10.1.223124123123-asdf\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}