# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/([\w\-]+)(.git)?(@([\w\-\.]+))?$"
test_str = ("https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git\n"
"https://github.com/defenseunicorns/zarf.git\n"
"ghcr.io/stefanprodan/podinfo_fasd-123.git\n"
"k3d-cluster.localhost/defenseunicorns/zarf-agent\n"
"localhost:5000/some-cool-image\n"
"ghcr.io/stefanprodan/podinfo@6.0.0\n"
"stefanprodan/podinfo.git@adf0fasd10.1.223124123123-asdf\n"
"https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git@0.0.9-bb.0\n"
"stefanprodan/podinfo@adf0fasd10.1.223124123123-asdf\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.