const regex = new RegExp('\\/([\\w\\-]+)(.git)?(@([\\w\\-\\.]+))?$', 'gm')
const str = `https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git
https://github.com/defenseunicorns/zarf.git
ghcr.io/stefanprodan/podinfo_fasd-123.git
k3d-cluster.localhost/defenseunicorns/zarf-agent
localhost:5000/some-cool-image
ghcr.io/stefanprodan/podinfo@6.0.0
stefanprodan/podinfo.git@adf0fasd10.1.223124123123-asdf
https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git@0.0.9-bb.0
stefanprodan/podinfo@adf0fasd10.1.223124123123-asdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}