#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/([\w\-]+)(.git)?(@([\w\-\.]+))?$"
Local $sString = "https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git" & @CRLF & _
"https://github.com/defenseunicorns/zarf.git" & @CRLF & _
"ghcr.io/stefanprodan/podinfo_fasd-123.git" & @CRLF & _
"k3d-cluster.localhost/defenseunicorns/zarf-agent" & @CRLF & _
"localhost:5000/some-cool-image" & @CRLF & _
"ghcr.io/stefanprodan/podinfo@6.0.0" & @CRLF & _
"stefanprodan/podinfo.git@adf0fasd10.1.223124123123-asdf" & @CRLF & _
"https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git@0.0.9-bb.0" & @CRLF & _
"stefanprodan/podinfo@adf0fasd10.1.223124123123-asdf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")