package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/([\w\-]+)(.git)?(@([\w\-\.]+))?$`)
var str = `https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git
https://github.com/defenseunicorns/zarf.git
ghcr.io/stefanprodan/podinfo_fasd-123.git
k3d-cluster.localhost/defenseunicorns/zarf-agent
localhost:5000/some-cool-image
ghcr.io/stefanprodan/podinfo@6.0.0
stefanprodan/podinfo.git@adf0fasd10.1.223124123123-asdf
https://repo1.dso.mil/platform-one/big-bang/apps/security-tools/twistlock.git@0.0.9-bb.0
stefanprodan/podinfo@adf0fasd10.1.223124123123-asdf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}