import Foundation
let pattern = #".*Voyage\:\\xa0{1}\s+([0-9]{4}[A-Z]{1}).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" \nSEASPAN LONCOMILLA\n\r\n Voyage:\xa0 1396S\r\n \n\n\r\n 10-Apr\r\n ALGECIRAS\r\n \n\n\r\n 01-May\r\n KRIBI\r\n \n\n'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}