using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*Voyage\:\\xa0{1}\s+([0-9]{4}[A-Z]{1}).*";
string input = @" \nSEASPAN LONCOMILLA\n\r\n Voyage:\xa0 1396S\r\n \n\n\r\n 10-Apr\r\n ALGECIRAS\r\n \n\n\r\n 01-May\r\n KRIBI\r\n \n\n'";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}