package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*Voyage\:\\xa0{1}\s+([0-9]{4}[A-Z]{1}).*`)
var str = ` \nSEASPAN LONCOMILLA\n\r\n Voyage:\xa0 1396S\r\n \n\n\r\n 10-Apr\r\n ALGECIRAS\r\n \n\n\r\n 01-May\r\n KRIBI\r\n \n\n'`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}