use strict;
my $str = ' \\nSEASPAN LONCOMILLA\\n\\r\\n Voyage:\\xa0 1396S\\r\\n \\n\\n\\r\\n 10-Apr\\r\\n ALGECIRAS\\r\\n \\n\\n\\r\\n 01-May\\r\\n KRIBI\\r\\n \\n\\n\'';
my $regex = qr/.*Voyage\:\\xa0{1}\s+([0-9]{4}[A-Z]{1}).*/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}