// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*Voyage\:\\xa0{1}\s+([0-9]{4}[A-Z]{1}).*").unwrap();
let string = " \\nSEASPAN LONCOMILLA\\n\\r\\n Voyage:\\xa0 1396S\\r\\n \\n\\n\\r\\n 10-Apr\\r\\n ALGECIRAS\\r\\n \\n\\n\\r\\n 01-May\\r\\n KRIBI\\r\\n \\n\\n'";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}