re = /.*Voyage\:\\xa0{1}\s+([0-9]{4}[A-Z]{1}).*/
str = ' \\nSEASPAN LONCOMILLA\\n\\r\\n Voyage:\\xa0 1396S\\r\\n \\n\\n\\r\\n 10-Apr\\r\\n ALGECIRAS\\r\\n \\n\\n\\r\\n 01-May\\r\\n KRIBI\\r\\n \\n\\n\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end