#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*Voyage\:\\xa0{1}\s+([0-9]{4}[A-Z]{1}).*"
Local $sString = " \nSEASPAN LONCOMILLA\n\r\n Voyage:\xa0 1396S\r\n \n\n\r\n 10-Apr\r\n ALGECIRAS\r\n \n\n\r\n 01-May\r\n KRIBI\r\n \n\n'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")