import Foundation
let pattern = #"\( \( '1' = '1' \) \) AND \( \((?:eQFetchRule[ ]*=[ ]*'(?:[a-zA-Z0-9\.]+):(?:[A-Za-z0-9]+)\(([A-Za-z0-9_]+)\)'[ ]*[or]*[ ]*)+\) \)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"( ( '1' = '1' ) ) AND ( (eQFetchRule = 'com.eq.chris.helloworld.fetchFunctionTable:RESULT(LOV__Management)' or eQFetchRule = 'com.eq.chris.helloworld.fetchFunctionTable:RESULT(LOV__CAE__Load__Geometry)' ) )"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)